The main issues related to this incident has either been resolved or have a work-around. We are still continuing to improve performance of the reports, but the core issue has been resolved.
Posted Jun 10, 2026 - 15:50 UTC
Update
We are continuing working on fixes for our reporting functionality.
Some issues with exporting the reports to PDF has already been resolved and released today at 11:30 UTC / 07:30 AM EDT. These fixes are available on the web now, and should be available in the app stores soon. So please, remember to update to the latest version if you are still experiencing issues with exporting reports.
We also have reports on issues related to missing of some graphs while exporting the reports on windows. We are investigating this issue, but until we have a fix ready for this, a work-around is to try on a mac, or through our app on android/ios.
Posted Jun 04, 2026 - 12:58 UTC
Identified
We have identified the root cause of some of the issues and are working on a fix. We are expecting to release the fix later today.
Posted Jun 04, 2026 - 09:50 UTC
Investigating
We are currently investigating and fixing reported issues with the reporting functionality.
Posted Jun 04, 2026 - 01:00 UTC
This incident affected: Hi Rasmus Core Functionality (Reports).